Scheduled Maintenance

Incident Report for Global-e Status Page

Resolved

The scheduled maintenance has been successfully completed.
Posted Mar 15, 2026 - 05:40 UTC

Investigating

We are currently performing scheduled system maintenance as part of ongoing improvements to our platform.

During this time, some services may experience brief and intermittent disruptions lasting a few minutes.

Between 04:00–05:00 UTC, the Global-e Admin will be temporarily unavailable, and file uploads may experience slight delays.

Our teams are actively monitoring the maintenance process. We will provide an update once the activity is completed.
Posted Mar 15, 2026 - 03:41 UTC